⚠ PharHub will be closed down in early 2023. More information

PharHub

Install phars via Composer

infection 0.26.15

AST based PHP Mutation Testing Framework.

Package infection
URL https://github.com/infection/infection/releases/download/0.26.15/infection.phar
Downloads 0
Release date
Available since
Requirements
{
    "php": "^8.0",
    "ext-dom": "*",
    "ext-json": "*",
    "ext-libxml": "*",
    "ext-mbstring": "*"
}
Replacements
{
    "infection/infection": "self.version"
}

Into a project:

composer require pharhub/infection '^0.26.15'

Into a project, but only for development:

composer require --dev pharhub/infection '^0.26.15'

Globally:

composer global require pharhub/infection '^0.26.15'

Note: To install any packages from PharHub, you need to add PharHub to your repositories first.
Please see instructions on the home page.