⚠ PharHub will be closed down in early 2023. More information

PharHub

Install phars via Composer

composer-require-checker 3.4

A CLI tool to check whether a specific composer package uses imported symbols that aren't part of its direct composer dependencies.

Package composer-require-checker
URL https://github.com/maglnet/ComposerRequireChecker/releases/download/3.4.0/composer-require-checker.phar
Downloads 267
Release date
Available since
Requirements
{
    "php": "^7.4 || ^8.0",
    "ext-json": "*",
    "ext-phar": "*"
}
Replacements
{
    "maglnet/ComposerRequireChecker": "self.version"
}

Into a project:

composer require pharhub/composer-require-checker '^3.4'

Into a project, but only for development:

composer require --dev pharhub/composer-require-checker '^3.4'

Globally:

composer global require pharhub/composer-require-checker '^3.4'

Note: To install any packages from PharHub, you need to add PharHub to your repositories first.
Please see instructions on the home page.